Funkcja Microsoft Excel CZY, której wynikiem są wartości PRAWDA lub FAŁSZ, jest przydatna do sprawdzania wyników obliczeń podczas analizowania raportów. Funkcja =CZY połączona np. z funkcją =JEŻELI jest świetnym narzędziem w rękach analityka i ułatwia sprawne analizowanie dużych ilości danych.

Data dodania: 2017-05-17

Wyświetleń: 715

Przedrukowań: 0

Głosy dodatnie: 0

Głosy ujemne: 0

WIEDZA

0 Ocena

Licencja: Creative Commons

Funkcje CZY w analizie Excelowej

Świetnym przykładem połączenia funkcji =CZY i =JEŻELI w jednym miejscu jest np.

=JEŻELI(CZY.BŁĄD(A1);"Błąd w Twoich obliczeniach";A1*10)

Ciąg myślowy w powyższym przykładzie jest taki: jeżeli w komórce A1 występuje błąd, wyświetl w komórce komunikat "Błąd w Twoich obliczeniach". Jeżeli w komórce A1 nie ma błędu, Excel przemnoży komórkę A1 razy dziesięć.

W funkcji =CZY możemy sprawdzać wiele parametrów. Poniżej możliwości funkcji:

• PUSTA,

• BŁ,

• BŁĄD,

• LOGICZNA,

• BRAK,

• NIE.TEKST,

• LICZBA,

• ADR,

• TEKST.

Poniżej przedstawiamy rodzaje i krótką charakterystykę wszystkich rodzajów funkcji CZY. Wynikiem działania będzie PRAWDA, jeśli:

• =CZY.PUSTA – będzie odwołaniem zadanym przez użytkownika, które będzie odnosiło się do pustej komórki.

• =CZY.TEKST – będzie odwołaniem do komórki z tekstem.

• =CZY.NIE.TEKST – będzie odwołaniem do zawartości komórki innej niż tekst. Wynikiem tej funkcji jest wartość logiczna PRAWDA, także w przypadku kiedy wartość odwołuje się do pustej komórki.

• =CZY.LICZBA – będzie odwołaniem do komórki, której zawartość to liczby.

• =CZY.BRAK – będzie odwołaniem do wartości błędu „#N/D!” lub braku wartości.

• =CZY.BŁ – będzie odwołaniem do wszystkich rodzajów błędów, poza błędem „#N/D!”.

• =CZY.BŁĄD – będzie odwołaniem do wszystkich rodzajów błędów (bez żadnych wyjątków) tj. „#N/D!, #ARG!, #ADR!, #DZIEL/0!, #LICZBA!, #NAZWA? lub #ZERO!”.

• =CZY.ADR – będzie odwołaniem do odwołania.

• =CZY.LOGICZNA – będzie odwołaniem do wartości logicznej.

Rys. 1

Przykładowe wpisy dla funkcji =CZY(), których wynikiem jest PRAWDA. 

vba, analizy danych, raporty, Excel

Rys. 2

Przykładowe wpisy dla funkcji =CZY(), których wynikiem jest FAŁSZ

analiza danych, raporty, visual basic, Excel

WAŻNE: W przeciwieństwie do wielu innych funkcji, funkcja CZY nie konwertuje na liczbę. Wszystkie wartości liczbowe, które użytkownik wpisze  pomiędzy znakami " " będą traktowane jako tekst.

Jako przykład pomiędzy " " wpiszemy wartość "20". Funkcja CZY.LICZBA nie jest skonwertowuje wartości pomiędzy " " na liczbę i dla Excela pozostanie ona wartością tekstową. Wynik tak zapisanej funkcji =CZY.LICZBA (sprawdzająca czy w komórce znajduje się liczba) zwróci wynik FAŁSZ.

Licencja: Creative Commons
0 Ocena