Funkcja WYSZUKAJ.PIONOWO służy do wyszukania i przyporządkowania do siebie wartości z dwóch lub więcej tabel. Obie tabele muszą mieć część wspólną, która pozwoli na połączenie danych.

Data dodania: 2017-03-03

Wyświetleń: 830

Przedrukowań: 0

Głosy dodatnie: 0

Głosy ujemne: 0

WIEDZA

0 Ocena

Licencja: Creative Commons

Fukcja WYSZUKAJ.PIONOWO w Excelu

Opis funkcji:

=WYSZUKAJ.PIONOWO (wyszukiwana komórka; przeszukiwana tablica; numer kolumny, z której dane będziemy wyświetlali; typ)

Opis części składowych funkcji:

  • wyszukiwane dane - wartość z tabeli 1, która wyszukiwana jest w tabeli 2 - część wspólna tabel.
  • przeszukiwana tabela - zakres danych, który przeszukujemy. Ważne, żeby w pierwszej kolumnie znajdowała się część wspólna, wyszukiwane dane, a zarazem identyfikator, który łączy tabele.
  • numer kolumny, z której dane będziemy wyświetlali - numer kolumny z danymi, które chcemy wyświetlić. Liczymy od pierwszej kolumny zakresu.
  • typ - wartość logiczna, 0 - dokładne dopasowanie.

PRZYKŁADOWE TABELE I WYNIK FUKCJI

Rys. 1 – Lista zakupów z pliku/zakładki nr 1.

analizy, excel, vba, wyszukajpionowo.pl

Rys. 2 – ceny produktów z pliku/zakładki nr 2.

analizy, excel, vba, wyszukajpionowo.pl

Celem zadania jest przyporządkowanie ceny produktów do jego nazw i dodanie jej do pierwszej tabeli. Szukaną wartością jest nazwa, tabelą, w której wyszukajemy, obszar komórek B2:C8. Ceny produktów znajdują się w drugiej kolumnie. Ostatni argument, typ, to 0, ponieważ chcemy znaleźć dokładne dopasowanie.

Dla powyższego przykładu funkcja będzie wyglądała:

=WYSZUKAJ.PIONOWO(B2;$B$2:$C$8;2;0)

Rys. 3 – finalna tabela po przyporządkowaniu wartości z obliczeniem.

analizy, excel, vba, wyszukajpionowo.pl

Dodatkowe informacje przy tworzeniu funkcji #1: Na potrzeby efektywnego używania funkcji -WYSZUKAJ.PIONOWO() przy analizowaniu danych, informacje w tabelach powinny być unikalne tj. nie powinny powtarzać się.

Jeżeli w tabeli, z której dodajemy dane, pojawia się więcej niż jedno powtórzenie wspólnego identyfikatora (np. jabłka, jabłka), funkcja WYSZUKAJ.PIONOWO przyporządkuje tylko pierwszą znalezioną wartość, pomijając kolejne. Tak samo, jeżeli w tabeli gdzie dodajemy dane, powtórzona jest komórka, do której przypisujemy dane, ta sama wartość pojawi się w pliku dwa razy.

Dodatkowe informacje przy tworzeniu funkcji #2: Jeżeli analizujemy dane, które znajdują się w tym samym pliku lub arkuszu Excelowym, trzeba pamiętać pamiętać o blokowaniu zakresów $. Inaczej zakres będzie się zmieniał, razem z przeciągniętą formułą. $ przed literą kolumny blokuje kolumny, $ przed numerem wiersza blokuje wiersz.

Licencja: Creative Commons