Funkcja SUMA.JEŻELI służy do sumowania tylko tych komórek, które spełniają odpowiednie kryteria.

Data dodania: 2014-03-13

Wyświetleń: 1641

Przedrukowań: 0

Głosy dodatnie: 1

Głosy ujemne: 0

WIADOMOŚĆ

1 Ocena

Licencja: Creative Commons

Funkcje w programie Excel: SUMA.JEŻELI

Składnia: SUMA.JEŻELI(zakres; kryteria; sumowany zakres)

Opis: Pierwszym argumentem funkcji jest zakres wprowadzanych danych, czyli wskazujemy te dane, z których będziemy pobierać komórki spełniające kryteria (drugi argument funkcji). Kryteria mogą mieć dowolną postać (liczbową, tekstową lub wyrażenia). Trzecim argumentem jest wskazanie komórek, które będą potencjalnie sumowane.

Przykład nr 1:

Załóżmy, że mamy wartość sprzedaży owoców

m7yU3AfAAAAABJRU5ErkJggg==
Rys. nr 1. Wartość sprzedaży owoców.

=SUMA.JEŻELI(A2:A9;"jabłka";B2:B9) Formuła oblicza sumę wartości jabłek (sumowane są wartości od B2 do B9)

=SUMA.JEŻELI(B2:B9;"<500";B2:B9) Sumowanie rekordów, których wartość jest mniejsza niż 500. W związku z tym, że zakres jest równy sumowanemu zakresowi powyższą formułę można skrócić do postaci =SUMA.JEŻELI(B2:B9;"<500").

=SUMA.JEŻELI(A2:A9;">p";B2:B9) Funkcja oblicza sumę tylko tych rekordów, które zaczynają się od litery p (przy czym gdyby był owoc o nazwie p, to byłby pominięty w sumowaniu.

Przykład nr 2:

W przykładzie nr 2 uwidocznione są dane nt. zebranych grzybów przez grzybiarza.

34j+ZWJ18ccAAAAASUVORK5CYII=
Rys. nr 2. Dane grzybiarza dot. zebranych okazów.

Zwróćmy uwagę na poniższe formuły (dla ułatwienia argumenty funkcji przedstawiono graficznie):

B9+wVTYYlACZAAAAABJRU5ErkJggg==
Rys. nr 3. Standardowe wykorzystanie formuły SUMA.JEŻELI.

Formuła przedstawiona na Rys. nr 3 wykorzystuje funkcję SUMA.JEŻELI w której zakres oraz sumowany zakres jest identycznych rozmiarów oraz zaczynają się od tych samych wierszy. Wynikiem tej formuły jest liczba 82 (sumujemy wartości dla tych komórek, których zawartość jest równa słowie Rydz).

Zobaczmy co się stanie, jeśli weźmiemy pod uwagę pierwszą komórkę w trzecim argumencie funkcji, natomiast pozostałe argumenty zostawimy bez zmian (Rysunek 4):

w8t7Jwhw1+NG+q6cyDniewHrGvw4sEnBtwM3LK02ccm8FW3uxIwmBQhAca7RPu4k8QqHAgKOVoCAbYutrdyJtZ2YUVKAABSUoYs5BPwfKJS8G9T8CpEAAAAASUVORK5CYII=
Rys. nr 4. Zaznaczenie tylko pierwszej komórki sumowanego zakresu.

Wynikiem nie będzie liczba zero jak można byłoby się spodziewać, ale 82. Wniosek z tego jest taki, że nie jest istotny rozmiar sumowanego zakresu, ponieważ rozmiar sumowanych komórek jest określany przez pierwszy argument funkcji SUMA.JEŻELI. Do czego zatem potrzebny jest sumowany zakres? Odpowiedź na to pytanie można znaleźć modyfikując trzeci argument funkcji dla Rys. nr 4.

Dla formuły z Rys. nr 5 otrzymamy liczbę zero co oznacza, że sumowany zakres wyznacza początek sumowanych komórek.

8BG8AcLcKBZiYAAAAASUVORK5CYII=
Rys. nr 5. Zmiana trzeciego argumentu funkcji na komórkę C3.

Uwagi:

  • Do funkcji SUMA.JEŻELI nie można przypisać argumentu, który posiada więcej niż 255 znaków
  • Zakres nie musi być identycznego rozmiaru co sumowany zakres

Inne  podobne funkcje: SUMA.WARUNKÓW, BD.SUMA

Licencja: Creative Commons